Generation/Re-Generate very slow

Red Barchetta
Posts: 14
Joined: 27 Sep 2016, 20:45

Generation/Re-Generate very slow

Post by Red Barchetta » 20 Jan 2017, 17:43

I now have over 1200 images in my gallery and the past couple of Generation runs when it gets to step 5, Generation Image Pages, it has started running very slow. I mean around 10 hours to generate the Page Images. I have re-booted, made sure I did not have anything running that would take up resources, checked my task/performance meters and found that there is very little CPU time and only about 1/2 of my 8gig memory being used. All files are stored on my local C: 2TB drive that still has over 500gb free. Any thoughts?

Generate Page Image 1239.html......

Maxim
Site Admin
Posts: 858
Joined: 02 Mar 2009, 17:02

Re: Generation/Re-Generate very slow

Post by Maxim » 20 Jan 2017, 20:23

Hmm. This is strange. I have to check it out. So, all image generation went fine and fast and when ETG started generating image pages - it started to run slowly. Right?

Red Barchetta
Posts: 14
Joined: 27 Sep 2016, 20:45

Re: Generation/Re-Generate very slow

Post by Red Barchetta » 20 Jan 2017, 20:47

Correct. Steps 1-4 no more than 5 minutes, then step 5 takes around 10 hours.

Red Barchetta
Posts: 14
Joined: 27 Sep 2016, 20:45

Re: Generation/Re-Generate very slow

Post by Red Barchetta » 20 Jan 2017, 21:05

The finished gallery is here: gt350.redshost.com

Red Barchetta
Posts: 14
Joined: 27 Sep 2016, 20:45

Re: Generation/Re-Generate very slow

Post by Red Barchetta » 21 Jan 2017, 07:53

It just finished another 10 hour generation. As a test, I removed pictures so I only had 1000, but it still ran slow on step 5. I'm going to try this on another computer and see what it does.

Maxim
Site Admin
Posts: 858
Joined: 02 Mar 2009, 17:02

Re: Generation/Re-Generate very slow

Post by Maxim » 21 Jan 2017, 10:46

Maybe it's the template? Can you test with different templates?

Red Barchetta
Posts: 14
Joined: 27 Sep 2016, 20:45

Re: Generation/Re-Generate very slow

Post by Red Barchetta » 21 Jan 2017, 21:50

I was just trying that, and that does seem to be the issue. I went from the Blue Box to the Black box and it generates in less than 30 minutes now. So it seems there is something in the template that is slowing down the image page generation. It seems to pause in step 4 at thumbnail index014.html but only for about a minute.

Maxim
Site Admin
Posts: 858
Joined: 02 Mar 2009, 17:02

Re: Generation/Re-Generate very slow

Post by Maxim » 22 Jan 2017, 12:13

OK, looks like the navigation drop-down list is the problem. I'll try to fix it and let you know.

Red Barchetta
Posts: 14
Joined: 27 Sep 2016, 20:45

Re: Generation/Re-Generate very slow

Post by Red Barchetta » 22 Jan 2017, 18:54

I was playing with the templates yesterday and for the most part, using any other template than Blue Box, generation would finish in 30-40 minutes. But with so many photos (1283 currently) using the simple navigation was very slow if I wanted to get to different areas. So I took the Black Box template and added the drop down navigation to the Thumbs pages, and generation went as normal. I then added it to the Images template, and once again, generation is taking 10+ hours. I come by here to report, and you have already found what I found out. I guess the process that writes the drop down in the Images pages is taking a long time as each Image page has a link to all the other 1283 Image pages in the drop down.

I opened the Resource Monitor and noted that most of the time, ETG is shown as Not Responding. CPU usage is very low and memory in use is 2.1GB (of 4GB total). But even with this, while ETG is Generating my computer is extremely slow, sluggish until the Generation has finished (or aborted).

Thanks for any help you can provide.

David

Maxim
Site Admin
Posts: 858
Joined: 02 Mar 2009, 17:02

Re: Generation/Re-Generate very slow

Post by Maxim » 23 Jan 2017, 12:47

Yes, David. Thank you very much for confirming the drop-down list issue. I'm on it already. Digging the procedure code down. I'll let you know when I have the results.

Post Reply